Scheduled Maintenance
Incident Report for Humata
Resolved
This incident has been resolved.
Posted Nov 11, 2023 - 16:32 UTC
Investigating
We are conducting a planned database upgrade and the site will be offline for roughly an hour.
Posted Nov 11, 2023 - 16:05 UTC
This incident affected: app.humata.ai.