Investigating outage of app.humata.ai
Incident Report for Humata
Resolved
We have resolved this incident are monitoring the status of our fix
Posted Oct 08, 2024 - 00:54 UTC
Investigating
We are currently investigating this issue.
Posted Oct 08, 2024 - 00:45 UTC
This incident affected: app.humata.ai.