Outage due to upstream provider

Incident Report for Humata

Resolved

Our upstream provider's services are recovering quickly around the globe. We are seeing improvement in error rates, and systems get back to operational.
Posted Dec 05, 2025 - 09:24 UTC

Investigating

We're currently experiencing connectivity issues, which appear to be caused by a widespread outage with our upstream provider. We're actively working with them to resolve the issue. You can follow their updates on their status page here:
https://www.cloudflarestatus.com/incidents/lfrm31y6sw9q
Posted Dec 05, 2025 - 09:12 UTC
This incident affected: app.humata.ai.