Planned Database Maintenance
Incident Report for Humata
Resolved
We have successfully completed our database maintenance
Posted Jul 08, 2024 - 22:31 UTC
Investigating
We are conducting a planned database migration.
Posted Jul 08, 2024 - 22:23 UTC
This incident affected: app.humata.ai.