Outage uploading new files
Incident Report for Humata
Resolved
This incident has been resolved.
Posted Nov 08, 2023 - 16:29 UTC
Investigating
We are currently experiencing an outage for processing new files which we are working to resolve
Posted Nov 08, 2023 - 16:17 UTC
This incident affected: app.humata.ai.