Outage of downstream provider

Incident Report for Humata

Resolved

This incident has been resolved.
Posted Feb 12, 2025 - 17:45 UTC

Investigating

Posted Feb 11, 2025 - 17:06 UTC
This incident affected: app.humata.ai.