Slow Processing Time for Uploads

Incident Report for Humata

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 15:52 UTC

Investigating

We are currently investigating this issue.
Posted Apr 01, 2025 - 15:47 UTC
This incident affected: app.humata.ai.