Outage of File Uploading

Incident Report for Humata

Resolved

This incident has been resolved.
Posted Apr 02, 2025 - 18:00 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 02, 2025 - 16:23 UTC
This incident affected: app.humata.ai.