Outage due to upstream provider

Incident Report for Humata

Resolved

Our upstream provider's services are recovering quickly around the globe. We are seeing improvement in error rates, and systems get back to operational.
Posted Jun 12, 2025 - 20:51 UTC

Identified

We're currently experiencing connectivity issues, which appear to be caused by a widespread outage with our upstream provider. We're actively working with them to resolve the issue. You can follow their updates on their status page here:
https://www.cloudflarestatus.com/incidents/25r9t0vz99rp
Posted Jun 12, 2025 - 18:59 UTC

Investigating

We are currently investigating this issue.
Posted Jun 12, 2025 - 18:34 UTC